Showing results for 
Search instead for 
Did you mean: 

BIOS bricking itself (twice now, B550-F)

Level 7

i've been the owner of a B550-F Gaming since February/21.

The board worked flawlessly from February until April, til one day, when i wanted to boot up the PC, it just got stuck at the DRAM Light and wouldnt work anymore.
I made sure, that every component was working as intended on another spare B450 Motherboard i had laying around and RAM aswell as CPU were working perfectly fine. This made me assume that the MoBo was faulty, maybe faulty BIOS or faulty hardware.

BIOS Flashback does not work. I tried several thumbdrives (cleaned with diskpart, several sizes, converted thumbdrives to MBR and all that stuff...).
Clearing CMOS does not work either (removed the battery over night).
Shorting CLRTC pins does not work (also overnight) - had a jumper plugged in

Sent the MoBo to RMA (to the (german) retailer i bought it from), it got back after around 3 weeks with a note saying "We couldnt replicate the problem, sending back with no change).
I decided to just try and see whether it would work for some odd reason... and to my surprise... it did.......... for one week.

Now i'm back at where i was 4 weeks ago... B550-F bricked itself, BIOS Flashback doesnt work (no light, nothing, doesnt even access the thumbdrives; they have indicator LEDs, when they're accessed).

I dont want to RMA it again to face the same problem 3 weeks later... i'm sure the retailer wont just give me a new one as a replacement (they arent known to be accommodating)...

ASUS B550-F Gaming
Ryzen 7 - 5800x
Corsair Vengeance RGB Pro 4x8GB
Seasonic GX-850

I'm starting to become desperate... It's become more and more stressful to move components around, desperation kicks in.

Thanks in advance!

Have a wonderful day.

Level 13
You aren't using AI Suite are you? If you are uninstall that and theres a cleanup tool hiding somewhere for it. I used Ccleaner. I had it brick both BIOS roms on one board to the point they never worked again. Thankfully that board still had socket roms and I was able to get replacements off fleabay for like $30 each. At first I thought it was the slickest thing since sliced bread and had sveral OC profiles saved. Had just finished doing some benches and #1 profile was default speed. I loaded that up to shut down and it BSODd and both roms bricked. That was an M8E and I havent used or even thought about using it since. Nothing there that cant be done in the BIOS and something about doing BIOS writes while you are up and running just doesnt sound like a good idea.