cancel
Showing results for 
Search instead for 
Did you mean: 

b550-i 1801 bios file issue

razlebol
Level 7
The new 1801 bios doesn't work

When I try to upgrade, it says the file is not a UEFI bios. I tried with the renamer and without it. Same issue.

Located here
https://rog.asus.com/motherboards/rog-strix/rog-strix-b550-i-gaming-model/helpdesk_bios/
2,738 Views
3 REPLIES 3

razlebol
Level 7
Tried downloading a third time today and it's working now. I guess they changed the file

I am not sure why you have created yet another thread on the topic. Version 1801 is old and I would NOT recommend it. I personally found it highly unstable.

Download the latest version from here:

https://rog.asus.com/uk/motherboards/rog-strix/rog-strix-x570-i-gaming-model/helpdesk_bios/

As of today 3402 is latest version, and I personally have found 3001 onwards to be a lot better than the older versions where you even had to set manual voltages to keep things stable. It is worth noting these issues have plagued ALL manufacturers on this chipset, so it is not just an Asus issue (it is an AMD issue).

The 1.1.9.0 and 1.2.0.0 AGESA versions seem to be a lot better in the whole. I have heard of some specific issues with the 3300X for example, but for most, these will be a big departure from the issues we had in November and December where systems were generally very unstable without manually setting voltages and the like.

1- The bios was released yesterday. They don't carry the same number from one board to another
2- This was because the file uploaded to their server was unusable and corrupted.