Showing results for 
Search instead for 
Did you mean: 

B550-F Gaming Wifi II stuck on splash screen due to USB devices

Level 7

I've swapped motherboard from MSI and ran into an annoying issue - when powering up the pc it get's stuck on bios splash screen. Hitting F2/del at that point won't do anything and after about a minute or two the computer restarts itself and goes into bios setup.

I've tried CMOS restart, bios update, reseating memory sticks and gpu and nothing. Then I tried to unplug all cables except of display ports and it did boot up without a problem. Fiddling around a bit more showed that it's caused by too many USB devices plugged in. So I've unplugged one device and it boots. But of course this is kinda annoying as I have to unplug one device each time I reboot/start the computer.

It doesn't seem to matter what device I unplug. Keyboard, mouse, microphone...

I have Ryzen 5900X, 64GB RAM and 3090FE. 1000W Corsair PSU.

This exact setup worked before I swapped motherboards. Any ideas how to fix it please? Or is it a faulty mobo? Thank you!