cancel
Showing results for 
Search instead for 
Did you mean: 

B450-F Unable to Install Windows into Samsung 990 Pro

MrWorldwide
Level 7

Hello,

We've been at this for some time now so I'm hoping to get some guidance on this.

Problem: We keep getting the winload.efi missing error after install. We also cannot see the Windows Boot Manager on the BIOS for the new SSD.

We upgraded the CPU, GPU, and SSD and kept our older (but compatible) motherboard. Current hardware is as follows:

  • Motherboard - Asus B450-F (BIOS version 5302, which is the latest)
  • CPU - Ryzen 7 5800x3d
  • New SSD - Samsung 990 Pro
  • Old SSD - Kingston A400 SATA 3
  • Old HDD - WD Blue
  • UEFI bootable USB with Windows on it made using Rufus

BIOS configurations: We've disabled fast boot, CSM, and attempted to disable secure boot but I'm not sure it worked. I say this because on the secure boot section, the "Secure Boot state" is greyed out. I've read on the ASUS website somewhere that "OS Type" = "Other OS" is what disables secure boot. I'm not sure how I would know for sure though. As far as I know, the above is the configurations that the BIOS should be in to install Windows correctly in UEFI mode.

Although this is the current configuration, we've tried many different iterations of these. We've redone the USB as well. We were able to install Windows successfully into the old SSD and get the Windows Boot Manager show up on BIOS for the old SSD. We just keep getting the blue screen with the winload.efi missing error with the new NVME SSD.

We've tried to install with all the other storage devices unplugged and have tried a few command prompt lines to try to fix the boot. Unfortunately we didn't get far as we got an "not authorized" error when trying to run the "bootrec /FixBoot" command. We also followed the following guide fairly well and unfortunately that didn't work either:
https://rog-forum.asus.com/t5/rog-gaming-notebooks/guides-windows-complete-quot-how-to-quot-clean-up...

The following is how disk manager looks with windows installed on the old SSD.

WhatsApp Image 2024-03-12 at 23.29.10_b500bb53.jpg

Any suggestions?

167 Views
0 REPLIES 0