cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix X470-F Gaming owners thread

AniChatt
Level 9
Hello guys, I am starting this thread for all Stix X470-F owners to discuss their overclock settings, issues etc. So that everyone get help quickly in a organised way. Installed my old 1600x in this mobo with 4011 bios and flareX 3200 with default docp and it works just fine without any issues so far. One thing to mention The board pushes 1.15v soc default docp profile. Is it normal seems a bit high for me as I have upgraded from B350-F gaming.
However a small issue I believe, the asus lighting control is not behaving normal. I mean just after login to windows it is taking a bit time to start (5min) before that if I try to on Lighting Control by clicking it, program crash window appears after few seconds. But when it starts on it's own then I can open asus lighting control. Anyone experiencing similar issue???
Also tried to use older version.
494 Views
2,438 REPLIES 2,438

AlleyViper wrote:
Have you tried to check if the MB has developed any significant bending, see how it rests over the mb tray (still flat?) and try temporarily with a light stock cooler just in case it's due to damage caused by a heavy cooler over time. It's not a LGA, but could be worth to check.


Yes. I have reseated the CPU and removed the cooler so it only rested on top and loosened mobo scews and it still no change

87808

OK! I have completely changed out the motherboard and i have discovered that I am still getting the same issues. If any RAM is present in the top 2 slots then it refuses to POST and i get this light for DRAM. it looks like my 3600 is to blame and not the motherboard? If so. I may purchase a 5600x to replace my 3600 and RMA it and later sell it. does the 5600x work on x470 prime pro? im on BIOS 5809.

My system works again. my 3600 was defective. Replacing it with a 5600x has allowed all 4 ram slot to work again.

Bobafunk95 wrote:
My system works again. my 3600 was defective. Replacing it with a 5600x has allowed all 4 ram slot to work again.


Good to know. Thanks for sharing the solution for your issue.

2021/02/09
14.77 MBytes
ROG STRIX X470-F GAMING BIOS 5837
1. Update AMD AM4 AGESA V2 PI 1.2.0.0
2 Update AMD RAID UEFI driver
3. Improve system stability

Download

ayonarith
Level 7
Just out of curiosity, anyone here have the new rtx 3000 series cards and its underperforming? ive tried almost everything that others have tried with no resolve. now im wondering if its possibly my motherboard that needs to be uptdated. im currently on bios version 4207 if i remember correctly, cpu is the 2700x. ive seen others with similar specs push out much more frames than i can.

and if i do update my bios with one would you guys recommend thats the most stable right now?

Does the option to update bios via internet not showing up in easyflash for anyone else?

Bobafunk95 wrote:
Does the option to update bios via internet not showing up in easyflash for anyone else?


I have the exact issue. Not sure what to do.

edit: I guess they took the ability out of the ez flash for the bios to be downloaded and installed right there; at least I don't see it. You have to DL the lastest bios, put it on USB and just select it in the ez flash section and it will read it and update to it. This time I was also able to load my profile afterwards and it worked, and that's the first time since I've had this board that its done that. Nice addition for me at lease.

ayonarith wrote:
Just out of curiosity, anyone here have the new rtx 3000 series cards and its underperforming? ive tried almost everything that others have tried with no resolve. now im wondering if its possibly my motherboard that needs to be uptdated. im currently on bios version 4207 if i remember correctly, cpu is the 2700x. ive seen others with similar specs push out much more frames than i can.

and if i do update my bios with one would you guys recommend thats the most stable right now?


have 2700x with this mb (x470f gaming) with bios 5603(no problems) and a rtx 3070 from inno3d x3 + 16gb ddr4 3200 CL16 ram. problem is that this cpu bottleneck hard on that card even at wqhd. its playable but i will try to run with a ryzen 5600x because u get 40+ more fps in many games. just watch benchmarks on youtube and you will see the difference.

I noticed that on latest BIOS PBO boost on my 5800X wont go past 5025mhz even if you it max it out.

BIOS 5809 I was able to run my 5800X up to (225mhz) 5075mhz rock stable. I could run it as high as I wanted but past (275mhz) 5125mhz it would crash.

BIOS 5822/5837 both have PBO boost locked at 5025mhz. Even if I put in 200mhz boost which should be 5050mhz(2850mhz +200mhz) it wont go past 5025mhz. Even going to 250mhz boost nothing, still 5025mhz.

Was wondering if anyone else has seen this with there 5800X or any other 5000 series CPUs?