cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix X470-F Gaming owners thread

AniChatt
Level 9
Hello guys, I am starting this thread for all Stix X470-F owners to discuss their overclock settings, issues etc. So that everyone get help quickly in a organised way. Installed my old 1600x in this mobo with 4011 bios and flareX 3200 with default docp and it works just fine without any issues so far. One thing to mention The board pushes 1.15v soc default docp profile. Is it normal seems a bit high for me as I have upgraded from B350-F gaming.
However a small issue I believe, the asus lighting control is not behaving normal. I mean just after login to windows it is taking a bit time to start (5min) before that if I try to on Lighting Control by clicking it, program crash window appears after few seconds. But when it starts on it's own then I can open asus lighting control. Anyone experiencing similar issue???
Also tried to use older version.
379 Views
2,438 REPLIES 2,438

Wheres_Waldo
Level 7
@AniChatt
Except that high voltages also result in higher heat. Besides, almost all overclockers are looking for Max overclock at Min voltage, not Max at Max.
I love computers but my passion is cycling. My Shapeways page.

Wheres.Waldo wrote:
@AniChatt
Except that high voltages also result in higher heat. Besides, almost all overclockers are looking for Max overclock at Min voltage, not Max at Max.


Exactly. And even without any OC it is hovering very close to throttling temp, which cannot possibly be right. Especially when a different bios version has it sitting 20C lower with exactly the same performance.
And I am not going to spend 150 EUR on a watercooler just to fix the symptoms of a buggy bios 🙂

Semicuda wrote:
Exactly. And even without any OC it is hovering very close to throttling temp, which cannot possibly be right. Especially when a different bios version has it sitting 20C lower with exactly the same performance.
And I am not going to spend 150 EUR on a watercooler just to fix the symptoms of a buggy bios 🙂


I'm using X470-F Strix with 2700X and single tower cooler. Using latest bios, Idle temp is around 45C and load temp can go up to 85C. I think it's not too bad? Haven't tried the original BIOS so can't comment on that.

poporange wrote:
I'm using X470-F Strix with 2700X and single tower cooler. Using latest bios, Idle temp is around 45C and load temp can go up to 85C. I think it's not too bad? Haven't tried the original BIOS so can't comment on that.


85c is high, but not stupidly so. You're good with that.

Here's hoping the next BIOS comes soon, and offers improvements. I'm tired of my memory being at 2666 (yeah, I know I shouldn't have got Hynix AFR, but I didn't know better back then)

Allikat wrote:
85c is high, but not stupidly so. You're good with that.

Here's hoping the next BIOS comes soon, and offers improvements. I'm tired of my memory being at 2666 (yeah, I know I shouldn't have got Hynix AFR, but I didn't know better back then)



there is news about memory prices will raise up , currently this the right time to purchase new one.

poporange wrote:
I'm using X470-F Strix with 2700X and single tower cooler. Using latest bios, Idle temp is around 45C and load temp can go up to 85C. I think it's not too bad? Haven't tried the original BIOS so can't comment on that.


https://www.amd.com/en/products/cpu/amd-ryzen-7-2700x give 85°C as max temp, so I'd say that is plenty high.

What's going on ASUS?

Look how many of us have spent £180+ on one of your products and left with all sorts of problems, most being stupid temps and voltage levels on the latest bios. Are Asus even going to release a new bios, checked everyday for weeks now and nothing.

They released a week ago a new BIOS for CH7. We should have the X470 Strix F soon.

deankenny wrote:
What's going on ASUS?

Look how many of us have spent £180+ on one of your products and left with all sorts of problems, most being stupid temps and voltage levels on the latest bios. Are Asus even going to release a new bios, checked everyday for weeks now and nothing.


I agree on this, the voltages are insane on auto.
Also was expecting a new bios by now to adress this because the negative offset does nothing for me with PBO enabled

Im using fixed voltage 1.31875 with LLC3 for now, which is enough for PBO scalar 10 with Performance Enhance 2

I bought this mobo and almost bought the Gskill F4-3200C16D-16GTZR, that is in the QVL list on the ASUS site.
I read at the Gskill site that the Ryzen optimized RAM is the F4-3200C16D-16GTZRX. I can't find the F4-3200C16D-16GTZRX, can i buy the F4-3200C16D-16GTZR ?
Thanks.