cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX X570-E GAMING WIFI II and the sound blaster G6

xfactor
Level 7
Just built a new amd system with ASUS ROG STRIX X570-E GAMING WIFI II

This has the latest bios and agesa 1.2.0.3 which I believe has the usb fix?

Anyway got the g6 plugged it in and it works fine for a bit. When I start a game eg battlefield 2042 I play if for 5 mins and the sound just stops. I have to unplug it and plug it in again for it to work. One time when I plugged it in, it blue screened my pc 😞

I thought this issue was fixed? What can I do? I like the G6 but this is unacceptable. Do other usb sound cards have the same issues?

Thanks
1,295 Views
2 REPLIES 2

xfactor
Level 7
I've tried all the ports on the back and the front case. I even tried a plugging the G6 into usb hub and the hub to the motherboard. It still cuts out audio after a minute or two of gameplay.

xfactor
Level 7
Ok an update. I went and set all the pci and m.2 to gen 3. I played bf2042 for a good hour or so and no drop outs.

Here's the thing, my cpu is the 5700G <- this only supports pci gen 3 not 4. However in the bios the modes you can select are Auto, gen1, gen2, gen3 for all the lanes connected to the cpu obviously.

But for the pci connected to the chipset it does list gen4! I initially set it all the gen3 and it worked. I decided to set it all back to auto and just change one at a time to gen3 to see which was the culprit.

First was the gpu. As this is only gen3 it made no difference, sound still cut out.

I have two gen4 m.2 nvme drives. One as windows boot drive connected to the cpu lanes, the other as a game drive connected to the chipset. I skipped the setting the boot drive as that only goes to gen3 as per cpu support, but the second one did indeed list gen4.

I set this m.2 to gen3 from auto and the rest all set to auto. No sound cut out so far.

So this is pci gen4 related. Which I thought was FIXED???. My plan was to use the 5700G until the new 3d vcache ryzens were available and then use the 5700g as second pc.

Do Asus know about this issue on this board? Are the older board fixed but maybe not this one as it's new? There is only the initial bios available for this board and nothing else.

UPDATE: spoke too soon as the sound cut out again. But not as quick as before. I might have to set everything back to gen3 and do more testing.

UPDATE 2: Set it all back to gen3 and sad to say it's gone back to cutting out. I'm beyond disappointed with this

UPDATE 3: I took out my Sound Blaster ZxR pci sound card from my old pc. Installed it into this amd system. When playing a game the left and right channels flip! Quitting the game and the channels revert back to the correct state. WTF is going on?