cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Strix X570-E Gaming Bios update?

thomson1969
Level 8
Hi,

Does anybody knows when there will be a new bios for this motherboard Asus ROG Strix X570-E Gaming.
The latest one is dated 2019-07-05, an there is nothing about which AGESA its using.
537,937 Views
1,337 REPLIES 1,337

" I am working as a tester it seems with no pay... It's not you buy it and expect it to work products anymore" - I agree with you, buddy, and that's why I gave up on upgrading to AM5 for the moment. All those issues with the memory overclocking, unstable systems, slow boot times because of the memory training (MCR doesn't help in all cases) and previously the reports about the CPU meltdown make me feel that I will be a tester for the first generation of AMD CPUs that support DDR5 (although the latest AGESA, which is yet to be released, promises to do miracles about high-speed memory support).  I have quite a stable system now and, in my case, I see improvements in the performance with the latest BIOS 4802 too - my best cores regularly boost over 5 GHz while previously 4.9 GHz was the best I could hope for.

There is no point to upgrade from am4 to am5 from my point of view, none at all. No performance gain whatsoever and it will cost grately, new MB new DDR5 new CPU to gain insignificant % which cannot be felt nor in games nor in tasks.

 

Few updates from my testing experience today: dissembled 3 machines to try and see what could be wrong with bios updates and to check if any of my current hardware  was preventing the MB to boot. Went overboard with disconnecting even the power button and starting the machine with screwdriver! With nothing attached to the board and 3 different CPUs one with integrated graphics, 3 different gpus and 3 different sticks of ram I've exhausted my options to update my bios version to the latest and greatest... Nothing seems to be working on my board with the last 2 bios updates! Even thought that I killed the board after not switching properly for so long.

IMG_20230721_223202.jpg

IMG_20230721_222732.jpg

IMG_20230721_230523.jpg

IMG_20230721_222750_edit_1409283325982712.jpg

So Asus I went above and beyond to exclude each component in my machine and with no options left I am left with your mercy. I simply wanted to update my bios but had to dissemble 3 PCs to conclude that it's just the motherboard. I got the worst of the worst it seems, it cannot update to the newest bios revision and boot...

Please if you think I've missed something while trying everything possible do let me know, I will definitely use kind words in my mind.

Have you tried forcing it into safe mode bios by turning it on and off a bunch of times? just wait for it to get stuck by looking at the QCode.

if you manage to get into the Bios either try reset it from there, and when that don't work try changing the fTPM to Discrete TPM instead of firmware, it'll block Win 11, but i've seen it make problems with my old 1080 for some reason.

Also try with an much older GPU or a newer RTX

I've tried with 3 graphic cards gtx970 1080ti and AMD Radeon one plus the integrated one in Ryzen 3200g - no luck, I must be doing something wrong? Right? Never had to do such gymnastics for an bios update...

I had to use an old GTX 660 for it to boot.

though if you don't have a Museum worthy GPU the best bet is to do the Safe mode boot first, turn on the PC then take the power from the PSU either by pulling the plug or hit the PSU switch( if it has one ) do this 5-10 times, and pay attention to the QCODE display, as AA and if TPM enabled 9E it is usually booted up, EDIT: It might have booted up without display

Arokhantos
Level 10

Couple of days with this latest 1.2.0.A agesa no issues so far no more edc bug so i wont have to use PBO2 Tuner anymore, also means i can use PBO on linux now which is more stable then Windows sometimes when AMD has radeon driver issues

 

ROG Strix X570-E Gaming/ Ryzen 9 5950x / 4x8 GB G.Skill Trident Z Neo F4-3600C16Q-32GTZN / Liquid Devil 7900 XTX / 2x samsung 980 PRO 2 TB / 2x samsung 860 evo 1 tb / 2x crucial mx500 2 TB / LG 38WN95C-W 3840x1600 144hz / 12 inch system info display

M3a1
Level 9

OK quick update, was watching random YouTube video and this PC had the exact same issue as my board. Top PCI slot set to auto is causing the problem it seems especially on those 2 bios update releases.

Here is the video, please note that it's not tested by me but it will definitely work as a fix if you use the bottom slot for your graphics card.

https://youtu.be/BfRLeCEdvq0

No idea if the dude managed to look at the issue further as he mentioned.

 

Thank you very much Asus for great bios updates breaking systems for users. Less tech savvy users please skip any bios updates unless providing crucial updates or skip Asus as brand entirely.

If any bios devs following this forum(doubt that) fix this annoying issue with those last bios versions. No high hopes here... Needless to say no more Asus boards for me in the feature. Republic of bull... It's easy to lose the trust build, hard to get it back...

Did you try putting the GPU in a different slot to confirm what you're saying? Strange how there are very few cases of this. The update seems to be working great for the majority of users. After flash, what Q-Code does the board get stuck on? Not sure you've mentioned that yet.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi, no did not test that i lost too much time with this. Error code was the same as the video i posted - and it does not seem to be isolated case - you can check previous comment replies that people actually used another gpu to boot after BIOS update.

TumKo
Level 7

Everything works fine for me and I use phanteks vertical gpu pci-e 4.0 full performance without loss or artifacts