Showing results for 
Search instead for 
Did you mean: 

Asus ROG Strix X570-E Gaming Bios update?

Level 8

Does anybody knows when there will be a new bios for this motherboard Asus ROG Strix X570-E Gaming.
The latest one is dated 2019-07-05, an there is nothing about which AGESA its using.
1,337 REPLIES 1,337

Everything will be fine, the only problem I saw was that my Windows 11 activation failed, I don’t know why, I had to enter the key again

^^Everything fine except for poorer performance.........

Pretty sure that it has something to do with the update of fTMP firmware

See this.

So 4802 is the last bios to apply then if we don't want to see a performance drop?


I can't say that I see any performance drops in benchmarks I run regularly - Cinebench R20/23/24 and 3D Mark. Also, my CPU clocks boost quite well, up to 5150 MHz. I haven't seen it reach that high since a long time ago with the same settings I have been using for years.

Level 9

UPDATE: once again my board declines to power on properly after bios update above 4408. Can just point one finger, guess which... Tested, ram, gpu, and whatever is there attached to the board. The only thing I did not test was the PSU. Don't tell me that's the issue...

High output current occur on the power supply at startup, check it with a load tester

its no that man i was joking, it powers on does the cycles check after fresh bios but does not post - just loops, last bios codes are 93 and b4 or b6 or something. Tried it all i have to accept that i cant update my bios to newer version, what a premium board with premium support and compatibility - for gamers ! Recent shaming of Asus was enough to get put me off ...

Have you tried removing everything from the rear/front IO? B4 is a USB initialisation issue.

Haven't seen any other reports of users not being able to update to these builds. Might want to contact service for your region.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

^^Or front panel connector?

I had a case reset button fail.  That is it wasn't quite making contact internally.  On the ohmmeter it registered  continuity when not depressed. Should have registered  infinite resistance (open).  The pc symptoms included random reboots while under noload, near the end the system would not post at all.  Upon disconnecting it,symptoms disappeared.