Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix B550-F Gaming (WiFi 6): No Post, No BIOS FlashBack

Level 7
I decided to build a secondary system as I sold my old one. I chose the Ryzen 5700G CPU as it was on sale, as I don't need much GPU power on my secondary system.

Anyway, I purchased a ASUS ROG Strix B550-F Gaming (WiFi 6) as I already have one with a 5800X CPU.

But when I assembled my new B550 and 5700G, and plugged in my 750W Platinum Seasonic Prime PSU with only 8-pin CPU power connector. Only my RGB lights came on my back panel area. No fans spin.

I then jumped the power on the front panel connector, and nothing.

I next tried to make a BIOS Flashback USB (FAT32) with only the latest BIOS on my other rig.

I then plugged the USB into the marked BIOS USB port, then pressed and help the flashback BIOS button for a few seconds and nothing. No lights flashing on the back of the back panel. Nothing.

Is this a MB issue? or a CPU issue? It would seem a MB issue, since the flashback does nothing?

I went through the documentation on flashback, plus watched the flashback video, then watched a few more on YouTube.

Thanks for any advice



CPU: 5700G
MB: ASUS ROG Strix B550-F Gaming (WiFi 6)
RAM: 32GB G.Skill F4-3200C16D 16GIS
PSU: 750W Seasonic Prime 80+ Platinum
SSD: Samsung 860 Pro SATA III 256GB

This is a benchtest setup in my workshop.

Hi MarkJohnson

You'll want to connect the 24-pin main power cable to update the bios.

Level 7
Yes, the 24-pin power cable is already connected.

Also, is the CPU needed at all to do a Flashback BIOS?

Level 7
OK, I called Asus. They told me a bunch of things to do, that had nothing to do with my problems for over an hour.

Finally, they got me to the fashback BIOS that I initially inquired about. They said I had the wrong BIOS file and he sent me one by email and said I should be fine and ended the call.

I decided to try the BIOS and I decided to use my trusty and reliable 64GB Kingston Data Traveler drive. I reformatted it and installed the BIOS from tech support and it turned on this time and started flashing. Then it went steady green. after 5-minute I shut it down as a steady light seemed incomplete or failed. It said the green light should go off if successfully flashed.

I then copied my new BIOS on the dtata traveler, and BIOS Flashback started for a few seconds then turned off. I think it just verified that I had the most current BIOS.

It still won't boot though? I mean it won't turn on at all. Just the RGB on the Asus logo cycles through the RGB colors. Nothing else.

I have a MB speaker I plugged in, and even put in a brand new one. and still no beeps at all of any kind.

It is like it doesn't recognize my CPU at all. I wouldn't think it is bad. I was a sold and shipped by Newegg CPU in unopened box.

Is there a special method to install these CPUs?

I reset BIOS with jumper. I pulled power, set BIOS jumper, and even pulled the battery all at once. and still nothing.

Level 7
OK, now I've pulled my 5500 XT video card from my other rig and installed it on the board. I thought maybe it might trigger it to work somehow.

Nope, nothing at all. Just a glowing Asus logo. No fans, no flashback BIOS anymore

I hope someone has some advice so I don't have to return my parts.

Hey Mark,

I'm not too familiar with AMD motherboards but I know how to use bios flashback.

1) Insert a usb flash drive into a usb port, make sure the flash drive is formatted to .FAT
2) Download the latest bios for your motherboard from the ASUS Support Center.
3) Extract the bios file onto the usb flash drive. (Don't just move the file)
4) Insert the usb flash drive into the bios flashback port.
5) Press and hold the bios flasback button until it starts blinking, the blinking should start slow and get faster and usually takes about 1-11/2 minutes. When the flashing stops the bios update is complete.

For a correct cpu install, you line up the arrow on the corner of the cpu with the mark on the motherboard. The cpu is not needed to do a bios flashback, all you need is the 24-pin main power cable connected and the psu switched on.


Level 7
Thanks nate, I already did that a couple of times with different BIOS.

I tried jumping the 24-pin power connector on the PSU to see if it would turn on. but it didn't. I had assumed it was bad.

I connected the MB to my other gaming rig and it powered on without a hitch. So I ordered a new PSU.

I then restored my other rig, then before I boxed up the old PSU for RMA, I decided to try testing it again, and Viola! It booted up and the PSU and MB are working fine.

Very weird. I had removed the PSU a couple times trying to reset the MB without success, but as soon as I put it in my main rig's PSU then it works. Very weird it also worked in my other rig afterwards.

I was looking at reviews and other posts on the subject of flashing BIOS for the 5700 and this seems a fairly common solution.

Somehow switching power supplies triggers the MB to recognize the CPU. Not sure how this could be possible. But I completely removed the PSU from my motherboard a couple times to make sure there was no residual power holding data on the motherboard as well as removing battery and clearing CMOS as well.

It is just baffling how a different PSU would make it start working again.

But at least I figured it out before RMA or returning anything.