Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Crosshair VIII Formula

Level 7
Hi All

I've got a problem with a brand new ASUS ROG Crosshair VIII Formula, BIOS 4201 (tried also one older version). BIOS Settings standard, only DOCP. Same symptoms without DOCP.

AMD Chipset Driver 4.09.xxxx tried also older version from ASUS Support Website.

- Intel LAN Adapter delivers only 100 Mbit instead of 1 Gbit (tried different drivers, actually
- Marvell LAN 5Gigabit is not working at all (no connection, LEDs at the Port are working sometimes) (tried different drivers, actually 10.0.22621.1)
- WIFI Adapter Intel AX200 not working (Cant find any WIFI network) (tried different drivers, actually
- Bluetooth not working (Cant connect any BT device) (tried different drivers, actually 10.0.22621.1)


- AMD 5800X3D
- RX 6900XT
- 2x16 GB Crucial 3600 CL16
- 1x WD SN850X
- 1x WD SN850
- Windows 11 (Fresh installation)

Strange thing is, when I go to Armoury Crate, I cant install the "lates" intel driver what it suggest to me. My driver is newer, but Armoury Crate cant see that. If i try to install this one, it will do the installation, it asks for restart and after that, I see the same screen as in the screenshot


Level 7
Can you see on the side of the box "production date"

Unfortunalety I have no box anymore. But the Board is new and it was already an RMA exchange...

Level 10
There is a serial number on the actual board,