cancel
Showing results for 
Search instead for 
Did you mean: 

Asus prime x570 pro doesn't start up sometimes

JarutheDamaja
Level 7
Hello
Apologies I've tried to use the search functions but i couldn't figure it out to only search posts that only includes this board.

So I'm a happy owner of the Asus Prime x570 Pro since November last year.
It's just that sometimes maybe it's once a week my pc doesn't start up when pressing the power button.
It just nothing happens, no power no post.

In the beginning I've just switched of the power supply, waited a few seconds and then it worked.
But after some months that suddently didn't helped anymore, even if i waited 10+minutes with switched off power supply (Power switch on the PSU)
I then removed the battery and measured the voltage, was around 3.2 volts, and i also noticed that it was heavier than 3 batteries of the same type i had from other devices.
However after inserting it, it worked right away.
Then it happened again, and because I'm lazy and don't want to open the case each time and configure the BIOS from scratch, i tried again the power supply trick.
And somehow i've noticed, that when i swich the powerbutton on the PSU and i put it in "half-position" you hear a little "bzzz" then it gives kind of a light bumb and pc starts.
That has worked a couple of months until last week where it didn't worked anymore.
Again i was lazy and didn't remove the battery and after some time "playing" around with the PSU it again started to work.

Now my question, did you ever heard of something similar? Or what do you think it is? Is it the board, is it the PSU?

I didn't do much overclocking, basically I just put the ram into DOCP 3600MHz, and i guess the PC is overclocking automatically when needed.
Ryzen Master software is Default. LED are all disabled. And i disabled the warning of the CPU fan because I'm using AIO.

What about the battery, why is it so heavy? They are not special batteries? Shall i replace it with a common one?
My guess it's the board, but i don't like to send it in for repair if not absolutly necessary.

Incase it helps, my specs:
Asus Prime X570 Pro
Ryzen 7 3800x
2x 16Gb Gskill Tridentz RGB 3600 Mhz DDR4
BeQuiet P10 850W PSU
2x SSD (nvme and Sata) and 1x HDD
GTX 980Ti

Thank you for any hints or tipps.
3,443 Views
2 REPLIES 2

JarutheDamaja
Level 7
It's solved, it was the PSU. However the PSU is still functional just unstable. Since I've switched it with another one - problems gone. Very weird.

Curious if you also updated the BIOS to 2407 (2020/07/03)?

This has an AGESA update which features "Improved DRAM compatibility". It solved a DRAM POST issue for me which I was having for months! 😄