cancel
Showing results for 
Search instead for 
Did you mean: 

A520M-E beeps normally but doesn't post

CTEoloAH
Level 7

Hello, I got a mobo A520M-E and a Ryzen 5 4500. The motherboard and CPU are new. But when I tried to run the system it beeps once and that's all, no post, no video, nothing. I've tried with 2 video cards RTX 3070 and GTX 1070, tried with different RAM sticks from 8GB up to 32GB, and tried with 2 different monitors. But nothing, only 1 short beep as a normal post and then nothing. Any idea what to do? I was thinking that maybe the BIOS is old and it's not compatible with R5 4500 but if the BIOS is too old why does the system beep as a normal post? I've checked and R5 4500 needs at least version bios 2423 from 2021. The last version is 3402, so Asus ships brand new mobos with over 2 years old bios? It's too bad that there is no info on the mobo for the BIOS version 😞 For example, on AsRock mobos there is a label on the bios chip with the current bios version and you always know if the bios is compatible or needs an update. Asus should take note from AsRock for that 😜

So, what to do? I'm not sure even if the bios are the problem because as I said the motherboard beeps normally as it should be. If the bios are incompatible then why beeps like that? I remember on other mobos if the bios are incompatible they don't beep or some of them don't boot at all. So, that's the problem? Old bios or not? For me isn't a problem to RMA the mobo because is new and the store accepts RMA for 30 days after purchase. But to be honest I want to use Asus, not AsRock for this build 🙂

145 Views
0 REPLIES 0