Showing results for 
Search instead for 
Did you mean: 

A little issue with an WDS500G2B0C in a CH VII Hero

Level 7
Greeting, Im here to consult you all about a little issue I have with an SSD M.2 NVME the WDS500G2B0C that a week ago I got to switch from two 240 SATA ones to only one M.2 installed in the slot one (bottom) in the first run all I did was to set everything to a new installation did nothing to the M.2 restarted and cloned the SO to the M.2, restarted, copied very thing from the old SSD's to the new one everything went smooth nothing bad and then turned off the pc and cut power to remove the old SSD's, next start I got a Windows 10 screen that can't find x file and windows needs to be fix... I thought something was wrong in the boot secuence in the bios so removed the other HDD's I have from the list and left only the M.2 to both from, restarted and started.. so thought that was all, so heres what the problem is; after a few days of moving things in the bios, checking the firmware with the Western Digital SSD Dashboard, already in the bios 3103 rolled back to 3004 for test, If i cut the power from the PC the SSD will not be detected in a cold start and I need to do a restart to be detected, if I only turn of the PC without cutting off the power everything will be fine, the same for restarts everything is fine unless I cut the power from the system. Right now is sitting in the slot 2 (top) as storage with the OS on the XPG S11 Pro 256GB in the slot one (bottom), already tested in both slots same error.

I know sounds petty "just don't cut the power" but for the electrical bill and my health (the PSU somethings can be triggered by spikes in the middle of night and wakes me up) so I looking some help/ideas here.

My rig:

Tipo de CPU OctalCore AMD Ryzen 7 2700, 3418 MHz (34.25 x 100)
Nombre de la placa base Asus ROG Crosshair VII Hero (2 PCI-E x1, 3 PCI-E x16, 2 M.2, 4 DDR4 DIMM, Audio, Video, Gigabit LAN)
Chipset de la placa base AMD X470, AMD Taishan, AMD K17 IMC
Memoria del sistema 16288 MB
DIMM3: G Skill TridentZ RGB F4-3000C16-8GTZR 8 GB DDR4-3000 DDR4 SDRAM (16-18-18-38 @ 1501 MHz)
DIMM4: G Skill TridentZ RGB F4-3000C16-8GTZR 8 GB DDR4-3000 DDR4 SDRAM (16-18-18-38 @ 1501 MHz)
Tipo de BIOS AMI (06/17/2020)
Aceleradora 3D nVIDIA GeForce GTX 1660 Ti
Controladora IDE AMD SATA Controller
Controladora IDE Controladora SATA AHCI estándar
Controladora de almacenamiento Controladora de espacios de almacenamiento de Microsoft
Controladora de almacenamiento Controladora NVM Express estándar
Controladora de almacenamiento Controladora NVM Express estándar
Unidad de disco WDC WD10EZEX-60ZF5A0 (1 TB, 7200 RPM, SATA-III)
Unidad de disco WDC WD5001AALS-00E3A0 (500 GB, 7200 RPM, SATA-II)
Unidad de disco WDC WDS500G2B0C-00PXH0 (500 GB, PCI-E 3.0 x4)
Unidad de disco XPG GAMMIX S11 Pro (PCI-E 3.0 x4)

Level 8
that honestly sounds like an issue with the nvme drive...

Just a fast update and sadly no real answer to my problem, no isn't a SSD problem I was busy to do test and without other PC with M.2 thats mine to do the tests, my brother has a pretty similar rig to mine, the only real change is that his rig has a Ryzen 1700 and a RX 590 and others SSDs/HDDs, today I got finally some real time to do test and green light from my brother and well.... his rig detects the ssd without problem from the first cold run (PSU cut off from the electricity) powering off and cutting power for 30mins turning it on and got detected it have the 3004 bios and flashed mine to the 3004 again to more test... So I did another thing I wanted from a few months ago; brought a PCIe adapter for m.2 (arrived today) for an old Optiplex 790 I have and use as editing/encoding rig, tested a XPG S11 Pro in and it got detected in the first run without problems, switched for the WD and it got detected the same without problem, same test powering it off and cutting the power, all cold starts got detected without problem... so is something with my rig in particular, so removed the 1660TI and tested with an old 7770 that is almost dead but stills gives image and no change still not detected in cold start.. the only thing left is the CPU... somehow my 2700 isn't compatible with this SSD but the 1700 is it..?

Tested the SSD in my brother and in my rig in the native m.2 slots and using the PCIe adapter, right now im really wasted and depressed to think anymore and my head is starting to hurt, i'll try other things later but for now my conclusion is that the life hates me.