Showing results for 
Search instead for 
Did you mean: 

4702 BIOS for Asus PRO WS X570-ACE broke Asus m.2 Hyper Card?

Level 7


I'm having issues with my AMD Ryzen build with a AMD Ryzen 3900X CPU and Asus PRO WS X570-ACE motherboard. I was running BIOS v4501, but yesterday I updated to the latest recommended v4702.

Ever since this update my Asus m.2 Hyper Card is no longer working as expected. Before the update I had 2x NVMe drives connected to the Asus m.2 Hyper Card running in PCI-Express slot 3 in PCIe RAID Mode. I also have 2x NVMe drivers connected directly using the two on-board m.2 connections, and a fifth one via the u.2 connector on the motherboard.

This worked perfectly, but after the BIOS update the second NVMe drive connected via the Asus m.2 Hyper Card won't show up no matter what I do.

I have tried to run the PCI-Express slot 3 in both x8 mode and PCIe RAID mode. In 8x mode neither of the NVMe drives connected to the Asus m.2 Hyper Card will show up. In PCIe RAID mode one out of two will show up. I tried to move the Asus m.2 Hyper Card card from PCI Express slot 3 to slot 2, but this gives the same behaviour. When slot 2 is running in "Auto" none of the NVMe drives connected to the Asus m.2 Hyper Card will show up, and when running in PCIe RAID Mode only one will show up.

I tried to remove both NVMe drives from the Asus m.2 Hyper Card and connect them one-by-one, and both NVMe drives work when running just 1x NVME via the Asus m.2 Hyper Card, but both will never work when both are connected at the same time.

I have tried to reset the BIOS and everything but nothing works. This was no problem when running v4501. Is v4702 broken? Why would this work any different running v4702 compared to v4501?


Is there some way for me to downgrade the BIOS back to v4501?