cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to mount pump head of ROG Strix LC II ARGB to CPU on ROG Crosshair VIII hero

atrab
Level 7

Please help, Asus customer service has no solution. They just keep reiterating that I follow instructions with proper parts. They do not address the fact that the threads do not match. This has been the most frustrating customer service issue I have ever had. I do not have a lot of experience with builds. I am placing a ROG Crosshair VIII hero motherboard into a fractal define 7 XL case. I am attempting to mount a ROG Strix LC II 360 ARGB cooler. I have fans and radiator mounted, but I can not mount the pump head to the CPU. The directions are confusing to me. I have removed the existing CPU cooler mounting brackets ( 2 narrow black strips). I tried to install the 4 standoffs that came with the cooler for an AMD mount, and none of the threads would screw into the CPU backplate. I opted to use the original standoffs that had the proper thread instead. The directions show placing a black plastic collar over the standoffs, and then attaching the pump head mounting plate to the 4 standoffs. However, when I attempt to do that it is obvious it is not possible. The rubber collars are the same height as the standoffs, therefore no thread protrudes above it to attach the nuts to. One other thing I am unsure of, with the 4 standoffs screwed down all the way the backplate is very loose. I would guess a good 1/16th to 3/32 inch gap between backplate and rear of motherboard. Any help would be appreciated. I have a case open with Asus, but will not hear back on the weekend I am sure. Either I am missing the proper standoffs, or I am misreading the directions. I don't know what else to try. I will attach a picture. I will only have 2 of the 4 rubber collars installed in the picture.

1000005674.jpg

104 Views
0 REPLIES 0