cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Ryujin III 360 ARGB LCD not recognized

assembly
Level 9

After turning on the computer today, I entered the system and found that the USB was not recognized and it was a Ryujin III LCD. This happened in January this year, and it returned to normal after re-plugging and unplugging the Ryujin III LCD USB cable.
Five months later, the condition recurred and was again resolved with reinsertion.

what is the reason?

 

264 Views
8 REPLIES 8

Aureliannn_ROG
Customer Service Agent

Hi @assembly ,

Thank you for your question. 

As there can be different reasons for the issue you encountered, we suggest that if you experience the problem again, kindly record Armoury Crate logs for our reference. 

The log files contain detailed information about the software's operation and can help us identify the problem.

Please ensure that the logs accurately record the occurrence of the issue.

Here are the steps to collect Armoury Crate log files:
Please refer to Q5: What is APP Diagnostics? (New Feature) in the attached article.

https://www.asus.com/TW/support/FAQ/1043747/#a14

Once you have completed the steps, please upload the collected log files to a cloud storage service and send us the link via private message. Also, please provide us with your product serial number.

Thank you for your understanding and cooperation.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

How are AC logs delivered to you?

Hi @assembly ,

please follow the steps below to record the logs. After completing the steps, a log file will be generated. 

Please upload the file to a cloud storage service and provide us with the link via private message.

Here are the steps to collect Armoury Crate log files:
Please refer to Q5: What is APP Diagnostics? (New Feature) in the attached article.

https://www.asus.com/TW/support/FAQ/1043747/#a14

Once you have completed the steps, please upload the collected log files to a cloud storage service and send us the link via private message. Also, please provide us with your product serial number.

Thank you for your understanding and cooperation.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

dzocece
Level 7

My issue is that. Whenever I boot my PC first thing in the morning. The LCD has no power or display. I still need to unplug and plug the power cord in order for the LCD to display the LOGO 

Does a window that says the device cannot be recognized appears when you enter the system?

No, no error prompt after boot but the no LCD display. turning it on via AC doesn't work either. Makes me wonder why. It seems like there is no power coming from the usb header. the AIO pump is working fine. 

It seems to be different from my situation.
When I turn on the computer, the LCD displays the ROG LOGO, but it cannot be recognized when entering the system. The LCD only displays the preset ROG LOGO.