Showing results for 
Search instead for 
Did you mean: 

rog ryujin iii 240 stuck on 0105

Level 7

hi, My rog ryujin iii 240 firmware is stuck on 0105, I tried to update to 0108, seems to do the update, but afterwards its back on 0105 after the update ?

puzzled, does anyone know why, or a fix.. 




Customer Service Agent

Hi @Johnhenrybond ,

Thank you for reaching out to us. We would like to gather more information regarding your issue.

  1. Could you please confirm if you are trying to update via Armoury Crate? 
  2. Have you encountered any error messages? If so, could you please provide screenshots of the error messages?
  3. Have you tried uninstalling Armoury Crate using the official Armoury Crate uninstall tool and then reinstalling the software? 

If you have reinstalled the software and the issue still persists, please provide the Armoury Crate logs for our reference. 

The logs contain detailed information about the software's operation and can help us quickly identify the problem.

Please ensure that the logs accurately record the occurrence of the issue (start logging > update ROG Ryujin III 240 > update completed without version change > stop logging).

Here are the steps to collect Armoury Crate logs:
Please refer to Q5: What is APP Diagnostics? (New Feature)

Once you have completed the above steps, please upload the collected log files to a cloud storage service and send us the link via private message. 

Also, please provide us with your product serial number.

Thank you for your understanding and cooperation.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.